Wordpress HTTPS doesn't work out of the box on Online.net Shared Hosting


#1

I’m using Shared Hosting, with https enabled on it.
When I place Wordpress php files into the site, http displays things fine, while https is displaying incomplete/buggy webpage (no CSS, no pictures)

Even if I do the complete initialization, http is working fine at the end, while https is buggy.
http://www.luoss.fr/wordpress/
https://www.luoss.fr/wordpress/

Modifying “wp_options” -> “siteurl” and “home” in order to write https instead of http, does nothing helpful : the wp-admin isn’t available anymore (redirection loop). Same problem when adding to wp-config.php :

//Use HTTPS for WordPress
define('WP_HOME','https://www.luoss.fr/wordpress');
define('WP_SITEURL','https://www.luoss.fr/wordpress');
define('FORCE_SSL_ADMIN', true);

I saw on the documentation that a plugin can be used (Really Simple SSL). It solves the problem, but it’s not fine. I don’t want to place an unofficial plugin containing thousands of workaround code lines to simply enable something simple that should have been working out of the box.

When I put a wordpress into an Apache2 / Linux server with https enabled, Wordpress on https works fine out of the box without any thing to do or any unofficial crap to install.

If somebody knows what is malfunctioning with the default Wordpress installation, HTTPS, and Online.net Shared Hosting, I’m interested !

Thank you in advance


#2

I guess there is something wrong here, already :

How to repair that ? As the server says it’s on port 80 (and may be http instead of https), Wordpress is malfunctioning (redirecting to https despite the fact it’s already into https, again and again, and probably lots of others things like wrong links.