Ubuntu 18.04: ppa.launchpad.net times out, everything else seems to work


#1

I have been trying to debug this for hours and I’m slowly descending into madness.

This morning I set up a fresh C2M in AMS-1 with Ubuntu 18.04. Nothing fancy I thought.
During the setup process I was trying to use some PPAs, e.g. for letsencrypt/certbot. Long story short:

W: Failed to fetch http://ppa.launchpad.net/certbot/certbot/ubuntu/dists/bionic/InRelease  Could not connect to ppa.launchpad.net:80 (91.189.95.83), connection timed out
W: Failed to fetch http://ppa.launchpad.net/marutter/c2d4u3.5/ubuntu/dists/bionic/InRelease  Unable to connect to ppa.launchpad.net:http:
W: Failed to fetch http://ppa.launchpad.net/scaleway/stable/ubuntu/dists/bionic/InRelease  Unable to connect to ppa.launchpad.net:http:

is all I get. I have tried and checked the following:

  • apt update: works for every other repository, except PPAs
  • nslookup ppa.launchpad.net returns 91.189.95.83, which seems correct as I get the same result on every other machine I have access to.
  • I have tried adding a temporary DNSv6 server, or a different DNSv4 server.
  • I have tried both http: and https: URLs
  • I have compared everything I could think of regarding configuration to another server, a VC1M in the same location, to figure out what I may have misconfigured. The VC1M however is still on 16.04, so I didn’t get that far as this is my first time touching 18.04
  • I have not setup any firewall stuff yet. ufw is disabled as well. The default security group is applied, and nothing is blocked that I can think of. Either way, if outgoing connections to port 80 or 443 were somehow dropped I’d have noticed by now.
  • I can ping and ping6 other random hosts via domain or IP.
  • I have googled. Oh boy did I google. I’ve read a bazillion stackoverflow, github, and misc forum posts with similiar or related issues, pretty much all of which boiled down to either “launchpad is down” (it is not right now. Trust me. I’ve checked so much)

Also:

» ping -v 91.189.95.83
PING 91.189.95.83 (91.189.95.83): 56 data bytes, id 0x5903 = 22787

That’s all I get. No response for minutes until I ^C out of that.

» wget -O /dev/null http://ppa.launchpad.net                                                              1 ↵
--2019-03-12 13:06:17--  http://ppa.launchpad.net/
Resolving ppa.launchpad.net (ppa.launchpad.net)... 91.189.95.83
Connecting to ppa.launchpad.net (ppa.launchpad.net)|91.189.95.83|:80...

Yeah nothing, also for minutes.
But then – gasp – when I tried that command for the nth time, it suddenly worked?! I quickly ran sudo apt update to get those package indices, and it also worked without a hitch.

Well then I thought, guess that was just a temporary, multi-hour hiccup? –– It wasn’t. Or isn’t.

As of this moment, I’m back to failed: Connection timed out.
I have no other option left than assuming that it must be some scaleway issue, because I have literally run out of every other thing I can think of to try/google.

Please. Save me.

EDIT 2019-03-12 13:20:48: I checked status.scaleway.com, found this regarding the global backbone, it says it’s stable now so I assume this is either unrelated or… well, not stable?

EDIT 2019-03-12 15:28:15: I have since given up, nuked the server and set up a fresh one in PAR-1. Everything is working fine there. At this point I’m fine with leaving it as-is, but I’ll still leave this here in case a scaleway-person sees this, notices if there’s an issue on their side, and fixes it.