The openvpn basic configuration blocks SMTP


#1

Hello,

I just take a scaleway server and I am delighted! bravo for your interface!

I mainly took the server to use OpenVPN.
(I had HMA VPN but it was far too slow, especially in the afternoon)

The installation from the imagehub was carried out very easily and my connection works perfectly.

Suel The problem is that my emails do not leave. All my SMTP servers are blocked when I activate openvpn. It is very strange because it worked seamlessly with HMA.

I use the basic configuration and I have not changed and neither tcp443.conf udp1114.conf files.

Do you have an idea ?


#2

Hi @carylonlinenet,

Have you unblock SMTP on your security groups?
If not, go to the security tab, select your SG and set Block SMTP to OFF.

Then, restart your server to apply the changes.

Edouard


#3

Thank you for your prompt response !
I don’t know where I can find this security tab ? Into my server conf file ? (/etc/openvpn) ?


#4

Hi,
You can find the security tab directly in your account : https://cloud.scaleway.com/#/securitygroups


#5

Thank you very much…I found it but :wink:

I set block smtp to off
I restart openvpn ( # /etc/init.d/openvpn restart)
I restart my openvpn local connection

The mail connection diagnostic (mac os) continues to tell me that SMTP is blocked.

I’ll look at all options of the security tab …
Do you think I missed something?


#6

Have you tried to reboot your instance from the control panel (by clicking on OFF > Hard Reboot)?
It is required to activate the new security rules on your server.


#7

Wonderful !
It works great now !!! I like Scaleway !