SSH Key invalid


#1

Hello,

First time trying to get a secure vps server going and really like Scaleways use of SSH. I am however having some trouble adding my public key to the web interface after creating a server.

I am using the latest version of puttygen (64-bit Release 0.68) to generate my public/private key. I have “SSH-2 RSA key” selected from the key dropdown, along the bottom i’ve selected “RSA” and left it at the default 2048. The only key that it would accept was a “SSH-1 (RSA)” key but the connection would not complete as it was not a ssh-2 key. I have tried generating several keys, of different lengths, with and without a passphrase.

Really not sure what else I can try.

Can anyone offer any suggestions as to where I’m going wrong?


#2

Just accepting the defaults and copy/pasting the key into scaleway panel should be fine. You will need to export the private key in ssh format if you want to use it from anything else other than putty.

I just tried adding a new key with the defaults SSH-2 RSA 2048 bits and it worked fine. That’s with puttygen 0.67

You will also need to shutdown/restart the server for the key to be added. A simple reboot won’t do it.


#3

I can’t offer any suggestions, but I’m having the same problem. And I’m using puttygen 0.67. And I had previously been able to do this (at least once and probably twice - once in May of 2016 when I first signed up, and again in May of 2017, when I moved to an ARMV8 server.)

[later edit: figured it out. I was copying and pasting only the visible part of the key. I eventually noticed that it didn’t appear to be terminated correctly (as in not proper base64). That’s when I figured out I had to drag the mouse pointer past the bottom of the box so that it would scroll and get to the end of the key. And then I realized I had some other alternatives for selecting the whole thing - like Alt-P or Ctrl-Home followed by Ctrl-Shift+End.


#4

This worked for me some time ago: https://www.scaleway.com/docs/configure-new-ssh-key/


#5

The fix for me was to remove the trailing newline