SSH issue when using Terraform to deploy kunernetes

#1

When I’m trying to use a Terraform to deploy kubernetes cluster ilm asked for organization I’d that I’m able to acquire but then I’m asked for access key that I don’t know where to get from tried the access key in scale away credintial didn’t work tried to create new SSH key but it asks me for a public key don’t know where to get it

#2

you need to create a new API token - and use the private token as “token” in the provider config for terraform file.

#3

Forgive for the my stupidity honestly but the API token should start with SCW Right?

#4

When I tried this before it gave an error running Terraform saying can’t access file /root/.ssh/id_rsa no file or directory found

#5

I didn’t use scw for this.
terraform has a config file - - lets say scaleway.tf

it contains

provider "scaleway" {
  organization = "Organisation TOKEN"
  token        = "private token generated in the web console"
  region       = "par1"
}

This works fine to connect and create / import resources.

#6

That’s it finally where can I get private key that shows on what console?!!!

#7

login on the web interface.
Go to your Account > credentials > API Tokens > Create new token

#8

Thanks alot for ur support. I’ll give it a spin in the morning hope it works. Thanks again buddy