[solved] Erreur de certificats proxmox

#1

Bonsoir tout le monde!

J’ai récemment installé un proxmox v5.4-13 sur lequel j’ai installé deux vm:

  • 1 vm firewall OPNsense
  • 1 vm alpine linux

J’ai appliqué des règles de NAT sur mon proxmox pour permettre aux vm d’avoir un accès à internet (test de ping ok).
Mon problème est que quand j’essaie d’installer un paquet ou de faire une update j’ai une erreur ssl de type:
“fetch https://dl-cdn.alpinelinux.org/alpine/v3.11/main/x86_64/APKINDEX.tar.gz
140176865000776:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:ssl/statem/statem_clnt.c:1913:
ERROR: https://dl-cdn.alpinelinux.org/alpine/v3.11/main/: Permission denied
WARNING: Ignoring APKINDEX.dd3d65ab.tar.gz: No such file or directory
1 errors; 136 distinct packages available”

dans le cas de la vm Alpine, j’ai essayer de changer les repos, vérifier la synchro ntp…

Concernant le firewall (essaie avec OPNsense et PFsense):

Si quelqu’un à une idée ou des proposition, je suis preneur :sweat_smile:

Merci d’avance!

#2

Salut !

A priori, le probleme viendrait plus des certificats que du NAT ^^
Est-ce que tu peux faire un curl basique pour verifier que tu as bien les certificats racine ?
Quelque chose comme curl https://github.com ? :slight_smile:

#3

Salut henyxia!
Merci (encore) de ta réponse ;).
curl retourne une erreur:

curl: (60) SSL certificate problem: self signed certificate

L’erreur se répétant sur des machines différentes (fw et classique), je trouvais étrange qu’une erreur de certificat se répète de cette manière.

#4

Le problème venait bien de ma règle nat masquerade. Il me manquait une option ("-o" avec la bonne interface).
Merci quand même pour ton aide henyxia! :wink:.
Bonne soirée.