[SOLVED] - Don't trust Scaleway for reliability


#1

Let me rant a bit, based on my recent experience with Scaleway baremetal servers.

I have had a server with a couple of volumes attached to it and everything was working fine. One day I decided that I need more storage. The only way to attach more volumes to a server is to shut it down, attach them and then start it again. That took a few minutes. But when I try to start my server I got an error of not being able to allocate resources for it. I thought that probably there were actually no available volumes. The UX could be better here. If no free volumes exist why let me create them?

But anyway, I removed the new volume and tried to re-start the server but I kept getting the same error. You see what happened here is that while my server was down and I was trying to figure out its storage it became unavailable. The only proposed solutions from Support is to either remove all extra volumes and start the server, which will be pointless since all my services data is on these volumes, or keep trying! Two days later my site is still offline and I’m keep trying.

So just because I trusted Scaleway’s terrible UX and documentation, I have no website running. So if you have a service that you want to be reliable find another provider. Because the time may come that you’ll need to shutdown the server to fix something and that is too risky here.


#2

Hello, we’re very sorry for the trouble caused here. We do have massive stocks replenishment planned in the following days and hope to solve the problem durably. Could you please provide us the email address from which you submitted your server account and your ticket number? We will take a look and offer you an alternative solution. Thanks


#3

Hi Imen,

I face a similar problem. Fortunately not so critical, since nothing in production runs on the server yet. The plan is to migrate our service to Scaleway but we are also “locked-out” of our server at the moment, since during volumes configuration the resources became unavailable.

You can check ticket IYER-2325-UWZY for more. The migration process was almost done, but if there is no storage availability we may have to check for other solutions.


#4

Do not trust scaleway for any critical services please. You will have just too much trouble. Chose another provider for critical apps. Scaleways sole purpose should be for testing environments.


#5

Well Scaleway is kinda cheap, so yes for testing and if you can live with all the trouble, it’s not that bad. For some personal and semi-professional setups or low-budget stuff it’s OK as far as I can tell from some months of experience and some of my collegues.

I still like the bare metal ARM servers for several reasons, the main thing why I keep one or two minimal servers running here.

But I can’t think of any of my “real/bigger” clients whom I could refer to Scaleway with all those basic problems they have, I can’t even migrate any of my own production services here due to the total lack of useful IPv6 support (in 2018! still can’t believe that state their IPv6 stuff is in… ).

The support is also pretty much useless, as is this community since still none of the devs or ops people seems to read or write here, only some poor 1st level helpdesk people.

I still hope for improvement, but I don’t see any and for now I can’t see any time soon that I’ll use more than one or two 2,99EUR play-servers here.

I guess it’s a waste of time to ask - once again - for some devs/ops people to show up here and talk a bit more about what’s happening and discuss how Scaleway could improve things? They rather hide behind some hyped blog posts some PR people come up, praising their work instead of discussion the issues? :wink:
bait


#6

Hi!
Sorry for the wait. We’ve identified your ticket and requested that our support team expedite action on it for you. You should see an update on your ticket shortly. Thanks.


#7

Unfortunately, in the end I have to agree with all the previous comments. After waiting for days the server was still unable to allocate resources. I also asked for a refund, since we paid for a server that we were unable to use for reasons beyond our powers, but with no luck. Scaleway refused to help and charged us like nothing was wrong on their side.

After this 1 month experience I concluded that Scaleway is hard to be trusted even for testing environments.


#8

Sorry you had to learn the hard way.

@Imen unfortunately scaleway does not seem to change or care, despite the fact you predicted otherwise. Very disappointing.

Edit: still waiting for the promised increase in resources for February.


#9

We truly are sorry for being out of stock and that you can’t allocate new ressources as promised. The demand for our instances has exceeded our expectations. There is a physical reality that undergoes several stages of production before we can ship new servers. We promised you massive stocks replenishment for February. We took a delay that is totally inadmissible, it’s totally our fault. The thing is, we clearly have underestimated our production deadline. As much as we try, we clearly failed to keep our promise due to a poorly anticipated management of stocks. This event does not reflect the level of service we want to offer you. We are currently processing new hardware and making sure that this does not happen again. This is our main focus right now.


#10

Thanks for the first honest and helpful answer, I think everybody will understand the issue with resources now and will be more patient.

However, It is not only about the lack of resources.

It’s mainly about the lack of information, lack of further development, missing reliability, missing network performance and overall performance and the honestly fast but poor support with mostly empty phrases and empty promises.

There is no certainty in scaleway at all.

We are still missing information about buckets, which are promised since years. What is the plan here? EOL? Give some information please.
“SIS Scale Up
We’re currently scaling up our SIS infrastructure to handle the load generated by all our new users. All new bucket creation are currently forbidden to preserve the service quality for current SIS users”
This is still displayed, which is showing you are not able to scale within at least 1,5 years? That’s ridiculous.

Scaleways network is quite poor, there is loss and other very slow transferrates quite often. Even between AMS and PAR, which is not acceptable. Scaleways network seems to be simply stressed too much. Why is this still an issue after months of complaining?
There are still lots and lots of issues with your network or at least with your storage system (i.e. shutting down and transfering an instance takes forever sometimes).

Concerning the lack of development, there are lots of people asking for very basic functionallity like adding additional disks (network disks?!) WITHOUT the need to shutdown the server for hours since months / years, Same for hot snapshots or simple backups without the need to shutdown running servers for hours. Still haven’t seen any real useful progress concerning those issues. Where is a public roadmap? This is so frustrating.

Support answers quite fast, but is not on point, mostly you get empty phrases or totally misinterpreted solutions. Don’t they understand the questions or is there no time to read the issues carefully? is english the issue and is the french support better?

There is absolutely no consistency in scaleway - which is why scaleway is not serious provider for now.

Time will tell, but the last ~2 years I’ve been with scaleway have been very disappointing and frustrating, in the very beginning I was very enthusiastic about scaleway, but my enthusiasm was very soon resplaced with frustration.

You simply did not deliver what you promised. - The only way to change my and lots of other peoples oppinion is to deliver. So, stop making excuses and start delivering your promises and I will be happy to recommend scaleway instead of warning people about it.


#11

Agree… I also had my servers down 3 times for longer than 1 day the last half a year. And this weekend was problem again my servers were unable to boot with error at the very beginning in iPXE… and support advised me just to boot in rescue mode…


#12

Hi there!

Our stocks are back! VC1 servers are now available in Amsterdam! We are shipping more servers for the coming days! All our team work very hard to make sure this does happen again and to deploy more!

Again, we are very sorry for the trouble that have been caused in the past days.
Have a great week!

Imen


#13