[SOLVED] Apt-get update not working


#1

Hi

I am experiencing problems when running the apt-get update command, I tried restarted the server but it didn’t solve the issue.

I would appreciate some insight as I’m clueless, I can ping archive.ubuntu.com
Here is the log:

apt-get update
Err:1 htttp://archive.ubuntu.com/ubuntu xenial InRelease
Temporary failure resolving ‘archive.ubuntu.com
Err:2 htttp://archive.ubuntu.com/ubuntu xenial-updates InRelease
Temporary failure resolving ‘archive.ubuntu.com
Err:3 htttp://archive.ubuntu.com/ubuntu xenial-security InRelease
Temporary failure resolving ‘archive.ubuntu.com
Reading package lists… Done
W: Failed to fetch htttp://archive.ubuntu.com/ubuntu/dists/xenial/InRelease Temporary failure resolving ‘archive.ubuntu.com
W: Failed to fetch htttp://archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease Temporary failure resolving ‘archive.ubuntu.com
W: Failed to fetch htttp://archive.ubuntu.com/ubuntu/dists/xenial-security/InRelease Temporary failure resolving ‘archive.ubuntu.com
W: Some index files failed to download. They have been ignored, or old ones used instead.


#2

Hello,

Just to be sure, you have a constant ping time ?
Maybe this was some transitory network issue (possible in AMS1) ?
You may try a traceroute if you have it (well traceroute -I thanks to [Ping works but not traceroute] (Ping works but not traceroute)
traceroute -I archive.ubuntu.com

Could you try this to check http transfert is working outside apt ?
wget http://archive.ubuntu.com/ubuntu/dists/xenial/InRelease
wget http://archive.ubuntu.com/ubuntu/ls-lR.gz


#3

Hi tykiki!

Yeah, it is constant:
ping archive.ubuntu.com
PING archive.ubuntu.com (91.189.88.152) 56(84) bytes of data.
64 bytes from steelix.canonical.com (91.189.88.152): icmp_seq=1 ttl=54 time=16.0 ms
64 bytes from steelix.canonical.com (91.189.88.152): icmp_seq=2 ttl=54 time=16.0 ms
64 bytes from steelix.canonical.com (91.189.88.152): icmp_seq=3 ttl=54 time=15.9 ms
64 bytes from steelix.canonical.com (91.189.88.152): icmp_seq=4 ttl=54 time=14.9 ms

I don’t have traceroute. I noticed that when I

Both work without a flaw.

I tried to install traceroute and noticed that my disk usage seems to be maxed out, I didn’t intentionally make it full.
I tried to use apt-get autoclean and apt-get clean, no success, really what is going on?

df -h
Filesystem Size Used Avail Use% Mounted on
none 998M 0 998M 0% /dev
tmpfs 201M 37M 165M 19% /run
/dev/vda 46G 44G 0 100% /
tmpfs 1002M 0 1002M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 1002M 0 1002M 0% /sys/fs/cgroup


#4

Depends, what’s using it?

Manually recurse down with du -h -a -d0 | sort -h starting from / and see what is using all that space.


#5

I really appreciate your help!

First I decided to reinstall Ubuntu, then after putting more thought into the problems I experienced with Ubuntu and the time I wasted dealing with them numerous times in the past, I decided to change the server distro to CentOS.

Thanks again.