[SOLVED] - Apt-get update failing on clean install


#1

hi,

I just spawned 2 servers with a debian stretch image ( START1-S / ARM64-2GB)
and on both the apt-get update is failing

W: The repository 'http://ftp.debian.org/debian stretch/updates Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.

I usually wouldn’t even notice but this cause ansible to fail
I dont even find this repo in /etc/apt/sources.list / sources.list.d/*

Input welcome!

Thanks.


#2

Hello @jsavalle,

It was indeed a known issue, which should have been fixed in our last Debian Stretch deployment.

Could you please raise a support ticket about your issue ?
What happens if you replace “stretch/updates” by “stretch-updates” in your sources.list file ?

Regards,
Mehdi
Customer Success Specialist
Online / Scaleway


#3

Indeed. it fixed it. Working like a charm now.
I spawned them 3 days ago - so maybe that was before it was fixed.

But anyway, now it’s fine!
Thanks


#4

btw, I have deleted the servers (and the associated volumes) - and the error remains.
I opened a ticket. It’s a shame default images don’t work out of the box.


#5

Same problem for me, on a START1-S, a START1-XS and a ARM64-2GB.
Their servers don’t even work properly on a clean install, what the hell. tss.


#6

Same problem for me today with fresh install of Debian Stretch with ARM64-2GB

In source.list I can see 4 lines, 2 with “stretch/updates” and 2 with “stretch-updates”.
After comment 2 line with “stretch/updates” everything working good.

Why this two line is still activated by default? (By default is Debian Stretch 9.4)