Slow connection speed (150kb/s) to hetzner


#1

Since April connections to Hetzner are often stuck at 150kb/s.
You can easily test by trying wget http://speed.hetzner.de/1GB.bin -4 -O /dev/null multiple times.
It’s like 50/50 chance to get a very slow connection. Just try it 10 times and you’ll see yourself.

--2018-04-13 17:02:14--  http://speed.hetzner.de/1GB.bin
Resolving speed.hetzner.de (speed.hetzner.de)... 88.198.248.254
Connecting to speed.hetzner.de (speed.hetzner.de)|88.198.248.254|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1048576000 (1000M) [application/octet-stream]
Saving to: ‘/dev/null’

/dev/null      0%[   ]   1001K   149KB/s    eta 1h 45m

Iperf to hetzner looks like this (when it’s happening):

[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-1.00   sec   334 KBytes  2.73 Mbits/sec
[  5]   1.00-2.00   sec   184 KBytes  1.51 Mbits/sec
[  5]   2.00-3.00   sec   232 KBytes  1.90 Mbits/sec
[  5]   3.00-4.00   sec   185 KBytes  1.52 Mbits/sec
[  5]   4.00-5.00   sec   266 KBytes  2.18 Mbits/sec
[  5]   5.00-6.00   sec   225 KBytes  1.84 Mbits/sec
[  5]   6.00-7.00   sec   221 KBytes  1.81 Mbits/sec
[  5]   7.00-8.00   sec  72.1 KBytes   591 Kbits/sec
[  5]   8.00-9.00   sec   102 KBytes   834 Kbits/sec
[  5]   9.00-10.00  sec   163 KBytes  1.33 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  5]   0.00-10.00  sec  1.98 MBytes  1.66 Mbits/sec  112             sender
[  5]   0.00-10.00  sec  1.98 MBytes  1.66 Mbits/sec                  receiver

Iperf online.net to online.net:

[  3]  0.0- 2.0 sec   226 MBytes   947 Mbits/sec
[  3]  2.0- 4.0 sec   224 MBytes   941 Mbits/sec
[  3]  4.0- 6.0 sec   224 MBytes   938 Mbits/sec
[  3]  6.0- 8.0 sec   225 MBytes   944 Mbits/sec
[  3]  8.0-10.0 sec   223 MBytes   937 Mbits/sec
[  3] 10.0-12.0 sec   224 MBytes   940 Mbits/sec
[  3] 12.0-14.0 sec   225 MBytes   945 Mbits/sec
[  3] 14.0-16.0 sec   223 MBytes   935 Mbits/sec
[  3] 16.0-18.0 sec   225 MBytes   943 Mbits/sec
[  3] 18.0-20.0 sec   224 MBytes   941 Mbits/sec
[  3]  0.0-20.0 sec  2.19 GBytes   941 Mbits/sec

It’s not only my server! I asked some friends, who also have servers at online.net and hetzner. They have the same problem. DC2 or DC3 doesn’t matter.
Also the hetzner DC doesn’t matter. The issue persists for 12 days now. Day or nighttime doesn’t matter. It’s 24/7 slow like this.

I don’t want to name my ticketnumber. I filed an issue with a reseller of online.net servers.
I doubt he even forwarded it. He just forwarded me some messages not looking like they were written by online.net staff. Then made a speedtest-cli and said everything is fine :smiley:
I don’t want to put my server in rescue mode anymore. It’s just a general issue with the networking at ANY online.net server. You can really test it yourself.
I would be really glad if you can forward this to your network team and make some tests. My routing is via NL-IX, which looks good on the network weathermap.


[ANSWERED] - Slow speed
#2

sorry to say this, but there is a huge general issue with scaleway / online.net network since quite some time and reoccuring, third or 4th time I am aware of long lasting network issues here. This thread is probably related: [SOLVED] Slow connectivity (TCP stuck to 1 Mbit/s)

Is it only hetzner for you other hosters too (i.e. ovh: http://ovh.net/files/ ) ? since the issue persists to a lot of other hosters, too.


#3

Everything is good except Hetzner.
OVH is like 80MB/s per connection. Leaseweb routing and other speedtest-cli tests are also good.
I think it was on 2. April, when I first noticed the 150kb/s cap. Like someone made a bad setting…
The online.net weathermap was good and no related issue/status on the statuspage of online.net or hetzner.
I thought it was a late aprils fool first :smiley:
But almost 2 weeks later I’m really concerned, that noone else is noticing or solving this.

It’s really unusable like this.


#4

I’m able to confirm the issue to Hetzner. Seems like similar issue we have with connectivity to T-Mobile Czech republic.


#5

they just KNOW and HAVE all the INFO but would NOT do NOTHING fokin online.net !!!


#6

unfortunately, scaleway / online.net is not known for fixing network issues fast as well as they are not known for a stable and working network. They are cheap and their network gear seems to be even cheaper. been here for couple of years now (~2k15) and already witnessed lots of those issues. sadly, they always took several months to be fixed.

If you need a reliable hoster, do NOT use Scaleway or online.net. i.e. switch to hetzner.com and use cloud, for redundancy use their second DC location in Finland.

Scaleway is not suiteable for any production or business environment at all. They do not provide resources (out of stock all the time), which is a key feature of a cloud provider, their support lacks quality answers, yet they seem to be fast, but who cares about speed if you issue isn’t resolved. And, their network simply is miserable.

Had to learn it the hard way, spent lots of time and effort in helping to fix their service, yet, they just seem not to care. Just empty promises. I.e. replenishment of resources in february, well now is april and they are still out of stock for most resources.

Scaleway is a hure disappointment and you should try to move to another hoster as fast as possible for your own good.


#7

i know someone from online.net techs reading this forum, please RENAME YOUR CLOWN COMPANY TO OFFLINE.NET and just close your whats so called online.net since ths is all JOKE wtf !!!