Please don't "enforce" specific browsers in the console


#1

I use GNOME Web as my daily browser, and both the old and the new console seem to work fine in it.

However, I was unpleasantly surprised when I saw a huge pop-up in the new console, that has to be explicitly dismissed, stating that the “app can not be run with an old version of web browser” (my version isn’t old: it is release 3.30.2 from the recently-released Fedora 29) and that I should “choose and install one of the modern browsers listed”.

I do not think Scaleway should be in the business of promoting specific web browsers, also considering the monopoly issues that have very often surfaced in the EU on the matter, and most of all, it should not claim a browser that, in fact, works with the new console “can not” do it.

If it’s not feasible to remove the message entirely, I would at least suggest

  • making it much less large, as it currently takes up a substantial portion of the screen,
  • making it disappear after the first user action, instead of having to be explicitly dismissed,
  • and whitelisting useragents of current browsers that work well enough.

For your information, my browser’s useragent string is

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.0 Safari/605.1.15

(I note that, like many other browsers, it has to partly lie about its identity because of sites that unfairly restrict browsers.)


#2

Hello,
Thanks for your feedback. It’s for sure a bug on our side. It’s not in our philosophy to block Linux browsers! This warning is just for browsers really outdated. We will release an updated version of the Console within this day fixing this unfortunate issue. We are sorry for this.


#3

Hi,

The bug has been fixed and the warning should not appear any longer. Let me know if you still have any issue with it.


#4

I can confirm the warning does not appear now. I tried it from Fedora 29 and Debian testing. Thanks, I appreciate it.


#5

I can no longer connect to the hardware console via the web interfaces - either old or new variant using Firefox/Linux. If I use Chrome/Linux it works fine. Firefox worked fine until very recently. Can you look into it.

Several other people have reported being unable to connect via the console recently in this forum.