pfSense and ipv6 configuration [Solved]

#1

Hi

I’m setting up a pfSense gateway on my proxmox server. I would like to configure an ipv6 address on it, but i’m a little lost on the configuration panel :

I try to set “send dhcp6.client-id < DUID >;” in field “send options” but … how and where do I add the ip address ?

Regards,

#2

Avec l’aide d’Ulysse sur IRC, voici donc la configuration pour que l’ipv6 fonctionne sur pfSense :slight_smile:

  • Le DUID doit être mis en binaire dans le fichier “/var/db/dhcp6c_duid”. Pour cela, j’ai suivi ce tuto :

echo <DUID > | awk ‘{ gsub(":"," "); printf “0: 0a 00 %s\n”, $0 }’ | xxd -r > /var/db/dhcp6c_duid

(nb: pour ma part, impossible d’installer xxd sur pfense, j’ai donc fait le fichier sur un linux, que j’ai ensuite scp depuis pfsense)

  • Dans System / Advanced / Networking, il faut cocher la case “Allow ipv6”
  • Dans l’interface Interfaces / WAN, sélectionner
  • “IPv6 Configuration Type” -> DHCP6
  • Dans “DHCP6 Client Configuration”,
  • Cocher la case “Advanced Configuration”
  • Mettre “DHCPv6 Prefix Delegation size” a 56 (taille de découpage de mon bloc ipv6 pour ce serveur)
  • Dans la partie de configuration avancée “Advanced DHCP6 Client Configuration”:
  • Send options = ia-pd 0,ia-na 0
  • Dans “Identity Association Statement”,
    • Cocher “Non-Temporary Address Allocation”
    • Cocher “Prefix interface statement”.
    • Mettre 0 dans “id-assoc na ID”
    • Mettre 0 dans “id-assoc pd ID”
    • Mettre l’adresse ip qui sera utilisée par pfSense dans “IPv6 address”
    • Mettre le préfix dans “IPv6 prefix”
  • Dans “Prefix interface statement” - “sla-len” mettre la taille de votre préfixe ipv6

Vous obtenez alors ca :

Attention : pour que mon bloc ipv6 fonctionne, j’ai du d’abord redémarrer mon serveur en mode secours sous ubuntu et configurer l’ipv6 dessus. Dès le reboot sur pfsense, l’ipv6 était opérationnel.

IPv6 for VM without IPFO IPv4
IPv6 for VM without IPFO IPv4
#4

Hello,
I followed your tutorial, but it doesn’t work for me. Please help.

Regards

EDIT: works now

#5

I tried it exactly like this, but everything i got was a blocked port. What did i do wrong?

I created the duid file with ubuntu, copied it to the pfsense and configured it as mentioned. In rescue mode everything was working fine. but not on pfsense.

Is it because i use esxi on my server?

Regards

#6

For information, if you want to provide ipv6 to VM behind pfsense without using ipv4, see the solution

#7

Hello,

I followed your instructions but never been able to get an IPv6 on my pfsense’s wan interface.
I don’t use proxmox but ESXi, does it matter ?

Did you use mac spoofing or something else ?

Thanks,