openSUSE Leap 15 Image


#1

Are there any plans to update the available openSUSE image to the upcoming Leap 15 release and make it available for more server types?

The image on GitHub hasn’t had any commits since 2016 and seems to only be available on C1 servers as openSUSE 13.2, not easily upgradeable to even Leap 42.3 in time for Leap 15 upgrade in 8 days.


#2

Do you need this image for a x86 or an ARM platform? Would you like a baremetal or a virtual instance?


#3

Hi, I’d be using this on the x86 START servers, either START-1XS or START1-S. This would also be a virtual instance I don’t really need baremetal for my use case :slight_smile:


#4

I think you can create an image that suite your needs using the following Scaleway tools: https://github.com/scaleway/image-tools First find the docker base image that suits your needs then follow the tutorial explained in the image-tools to get your OpenSuse image ready. I think the official OpenSUSE image are available here: https://github.com/openSUSE/docker-containers

I’m no expert in OpenSUSE by any means but let me know if you need additional information about Scaleway services.


#5

You’re right, I probably could use the image tools, but what if I want my base image to be openSUSE and run Docker on top of that instead? Especially with some of the changes made in Leap 15.
Docker is fantastic, but it isn’t a solution here. Especially annoying since Scaleway themselves advertise the openSUSE image as being maintained - maintained as in not updated since 2016? https://www.scaleway.com/imagehub/opensuse/


#6

Image-tools uses docker to build cloud images. You could you use image-tools starting with a image of OpenSuse Leap 15 and build your image on top of that.


#7

Ah, I understand now, thanks.

That still doesn’t solve the problem of the existing image claiming to be maintained by Scaleway when it clearly isn’t right now and seems to have no hope of returning.

If the core image is no longer maintained or wanting to be updated/supported outside of the C1 servers, then surely support and advertising of the image should be dropped entirely?


#8

I created a Baremetal C1 ARM server, choiced OpenSUSE.

After everthing up and running, I saw the server is under 13.2 version. Duhh.

I has a great idea, upgrade to Leap15, follow steps 13.2 > 42.1 > 42.2 > 42.3 > finally 15.0.

I tried to do upgrade, but the 13.2 repos is down. The simple “zypper ref” don’t work anymore.

I found this issue, and, if I understand, I need to build my own image if I want to use OpenSUSE with current version?


#9

@henrique

Apparently that’s the “solution” here, despite Scaleway insisting on their website that the openSUSE image is maintained. If this is no longer true, it needs to be removed from service and that page retired.

Quite disappointing given that a 42.3 image exists for AWS which is in theory upgradeable to 15.0 - Linode had 15.0 images available as of release date! I understand that Ubuntu/Debian and Fedora/CentOS are “more popular” but if this is the case and Scaleway are unwilling to update + expand the openSUSE image to more server types, the apparent false commitment needs to cease.


#10

image-opensuse is not present anymore on our github. At this time, not enough users request it to dedicate enough resources to maintain it.


#11

Scaleway is an ambitious company, with competitive prices and overall quite attractive. You claim to support openSUSE on your site here https://www.scaleway.com/imagehub/opensuse/. It is a shame to give such replies to people that try to do what you promise and it is even worse to delete github repos to justify your saying. I hope you will quickly take a serious look into this issue.