No IPIV6 lease for VPS issue ? Here's a workaround (?) until correction


#1

This may help someone.

Scaleway support confirmed there’s an issue with IPV6 leasing.
VPS didn’t get the IPV6 indicated in the administration console… :frowning:
No ETA resolution at this time.

The workaround could be found in SW doc itself : use the script for C2 server found here : https://blog.online.net/2016/03/31/introducing-native-ipv6-connectivity-on-scaleway/


# Load all IPv6 setting from the metadata service
IPV6_NETMASK=$(scw-metadata IPV6_NETMASK)  
IPV6_GATEWAY=$(scw-metadata IPV6_GATEWAY)  
IPV6_ADDRESS=$(scw-metadata IPV6_ADDRESS)  
# Add your IPv6
ip addr add ${IPV6_ADDRESS}/${IPV6_NETMASK} dev eth0  
# Add your default IPv6 gateway
ip -6 r add default via ${IPV6_GATEWAY} dev eth0  

Ideally this would better ran once a boot time :wink:, so I tried to save the script in a file and add it in the cron (crontab -e under root) :
@reboot /root/getipv6.sh

But this doesn’t work … as at the time of execution, the IPV6 variable are not set YET in /run/scw-metadata.cache ! :blush:

Even waiting a bit did not help … as probably the fork of the shell is also done to early ?!
@reboot sleep 30 && /root/getipv6.sh

So grab your ADDRESS, GATEWAY and NETMASK and set it in your script… better than nothing.

My 2 cents.


#2

Hello,

Thanks for your script :slight_smile:

The IPv6 issue has been fixed and new images supporting IPv6 will be available in the marketplace very soon.
Sorry for any inconvenience.

Benedikt


#3

Good to know ! :relaxed:

thx


#4

AFAIK problem still exists… and it’s furthermore also there on you new START1 offer (I’ve only tried ubuntu).

PS : I didn’t mentioned for the script; replace eth0 by your device (eg : ens2 …)


#5

Hello,

There is currently no DHCP server for IPv6. The address is taken from the scw-metadata and should be configured automatically on all of our images, if IPv6 is enabled for the instance.

Don’t hesitate to contact the technical assistance in case your instance does not configure its IPv6 automatically.

Bene