[need feedback] Please support CentOS (or at least Fedora)


#1

Great start! Love the service so far. I am limited in using it because of lack of CentOS support. Even Fedora support would be helpful.


#2

You can try to port CentOS or Fedora by yourself: https://doc.cloud.online.net/advanced/image.html

From what I see on forums, Fedora seems to be ported on our hardware (V20, V21)
But I can’t find port for CentOS

Don’t hesitate if you have any issues to port a distribution on our platform
We will also give a try to port the main distributions by ourselves, but it will be faster if the community does this, especially if some experts of the distros give help.


Official topic:


[OFFICIAL] New linux distributions (Debian, CoreOS, CentOS, Fedora, Arch Linux, ...)
#3

That’s helpful. Since this is not my area of expertise, I would really hope Online.net creates a supported image or at least provides official instructions. Also after searching, I didn’t find any instructions for fedora in the community. If online.net is trying to attract say - Amazon EC2 users, the Amazon Linux is based on Redhat/CentOS (as you may already know) - this seems important basic functionality.


#4

Does anyone succeed to start a server with CentOS / Fedora ?


#5

I think it will not be possible at this time. As Redhat have annouced on July 2014 an ARM:
" As a part of the expanded Core efforts, we are also going to attempt to
deliver a CentOS-7 release for 32bit x86, ARM and PowerPC in the coming
months."
We don’t see any progress on their side…


#6

So is Fedora possible?
If anyone gets either working, do reply back on this thread.


#7

There is no support for CentOS sadly. Like I mentioned earlier in IRC, after talks with a package maintainer for CentOS there is currently no support or planned support for ARM in the usual CentOS release cycle. The tips I was given was basically along the lines of “mirror the entire repository and recompile them all for ARM” which is not something I am going to enjoy doing!


#8

I got it working… From a Ubuntu server with 1 extra volume at /dev/nbd1

wget http://mirror.easyspeedy.com/fedora/releases/20/Images/armhfp/Fedora-Minimal-armhfp-20-1-sda.raw.xz
apt-get install xz-utils kpartx
unxz Fedora-Minimal-armhfp-20-1-sda.raw.xz
dd if=Fedora-Minimal-armhfp-20-1-sda.raw of=/dev/nbd1 bs=1M
kpartx -a /dev/nbd1
dd if=/dev/mapper/nbd1p3 of=nbd1p3 bs=1M
dd if=nbd1p3 of=/dev/nbd1 bs=1M
partprobe
e2fsck /dev/nbd1
resize2fs /dev/nbd1
mount /dev/nbd1 /mnt
nano /mnt/etc/passwd (edit '/etc/passwd' file and remove the 'x' from the line beginning with 'root')
nano /mnt/etc/fstab (comment 2 last lines out, and change UUID=blabla to /dev/nbd0)
umount /mnt
sync
nbd-client -d /dev/nbd1
shutdown

Then created, a snapshot of the volume, and create a new server with it…


#9

e2fsck /dev/nbd1
This step fails with error that /dev/ndb1 is in use. e2fsck: cannot continue aborting.
Any idea how to resolve?

Also, missing step is to “apt-get install kpartx”


#10

Try a partprobe else reboot… I think it because of the partition table, which we removed…


#11

Kristian_Klausen thanks for input.

but it produced an Network error : connection refused

Thanks


#12

You just need to wait, give it some time (5 min MAX)…
I not 100 sure, why it take so much longer… I think the backend system, is transferring the whole volume including free space, which it should not!..


#13

i think problem is here

nano /mnt/etc/fstab (comment 2 last lines out, and change UUID=blabla to /dev/nbd1)

/dev/nbd1 should be nbd0 as when installing it is generally installed on nbd0.


#14

You right :slight_smile: I forgot that…


#15

Seems @manfred started to work on that: https://github.com/online-labs/image-builder/blob/master/images/fedora-20/build


#16

@yann Can you take a look at centos and see if there is a way to make an image for that? http://centos.mirror.facebook.net/7/os/x86_64/


#17

Hi,

actually, there isn’t CentOS image for ARM architecture.


#18

Anyone successful in porting fedora?

Kristian_Klausen there is no ssh , even it not work in console, I had tried Adding up boot files using debootstrap, still it not work.

[nano /mnt/etc/fstab (comment 2 last lines out, and change UUID=blabla to /dev/nbd0)]

instead of /dev/ndb0 should we use volume id ?


#19

It worked here…

No? /dev/nbd0 is a block device “connected” with ndb-client from the initramfs… You mean UUID or labels or?


#20

At last i am able to boot fedora and it is accessible through putty.

Thanks to Kristian_Klausen , used his above post as base.

#Fedora

apt-get update
apt-get upgrade -y
apt-get install xz-utils kpartx

  1. wget http://fedora.mirrors.ovh.net/linux/updates/20/Images/armhfp/Fedora-Minimal-armhfp-20-20140407-sda.raw.xz
  2. unxz -v Fedora-Minimal-armhfp-20-20140407-sda.raw.xz

#Format nbd 1 using extension 4

mkfs -t ext4 /dev/nbd1

  1. dd if=Fedora-Minimal-armhfp-20-20140407-sda.raw of=/dev/nbd1 bs=1M
  2. kpartx -a /dev/nbd1
  3. dd if=/dev/mapper/nbd1p3 of=nbd1p3 bs=1M
  4. dd if=nbd1p3 of=/dev/nbd1 bs=1M
  5. e2fsck -f /dev/nbd1
  6. resize2fs /dev/nbd1
  7. mount /dev/nbd1 /mnt
  8. nano /mnt/etc/passwd (edit ‘/etc/passwd’ file and remove the ‘x’ from the line beginning with ‘root’)
  9. nano /mnt/etc/fstab (comment 2 last lines out, and change UUID= to /dev/nbd0) & add rw

#it will look like this

UUID=/dev/nbd0 / ext4 rw,defaults,noatime 0 0

  1. nano /mnt/ /etc/sysconfig/network-scripts/ifcfg-eth0

#add these lines

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

  1. umount /mnt
  2. sync
  3. nbd-client -d /dev/nbd1
  4. shutdown

Then created, a snapshot of the volume, and create a new server with it…
Access server from console and give this command

mount -o remount,rw /dev/ndb0

  1. passwd [ Set password and access server through putty]