[need feedback] Add Arch Linux ARM image


#1

That will be nice :slight_smile:


#2

Official topic:


#3

Me too, but thats because I’ve been engrossing myself in Arch on my Dedibox XC. Switching back to Ubuntu is confusing :slight_smile:


#4

Does anyone succeed to start a server with Arch Linux ?


#5

Yeh, my server is running Arch Linux ARM right now…


#6

Yeah, congrats!

Can you list the modifications needed ?

:smile:


#7

I just created a extra volume, formatted it ext4.
Then I downloaded http://os.archlinuxarm.org/os/ArchLinuxARM-armv7-latest.tar.gz and extracted it to that volume, created snapshot and new server, and it worked…
I then added /dev/nbd0 to fstab, so it get mounted rw.


Add Slackware ARM image
#8

Are you using systemd ?

Did you port some scripts from upstart to systemd ?
https://github.com/online-labs/image-builder/tree/master/images/ubuntu-trusty/patches/etc/init

Nice work


#9

Yes I’m using systemd.
I haven’t ported any script… At the moment, I’m trying to see if there a better way todo what nbd-disconnect-root do…


#10

Ok, and what about the ssh key syncing ? are you using an hardcoded password ? did you manually added your authorized_key file ?


#11

That tar archive I downloaded and extracted default login is, root and root


#12

Ok, so we know Arch Linux runs on our servers : \o/

Now, we need to port the upstart scripts to we can create an official image that people can boot with their volumes and ssh keys


[OFFICIAL] New linux distributions (Debian, CoreOS, CentOS, Fedora, Arch Linux, ...)
#13

Can you try adding “–systemd-mark” to your initramfs? That should solve kernel panic because nbd root get unmounted. Wouter Verhelst is working on a systemd service which unmount nbd not-root mount correctly. https://twitter.com/wouter_verhelst/status/523073956040163329 http://lists.freedesktop.org/archives/systemd-devel/2014-March/018053.html


#14

Ok, we will release a new initrd with --systemd-mark, I will need your server-id to manually configure it to boot with the new initrd


#15

1ca8aedb-29f4-4c23-ad7d-c4f32cde3d15 Thanks! :slight_smile:


#16

You can restart your server, it should add the option, tell me if it works.


[OFFICIAL] New linux distributions (Debian, CoreOS, CentOS, Fedora, Arch Linux, ...)
#17

It won’t start.
transferring data (Cannot start server. (last state: kernel-started))
What version of nbd, did you include in the initramfs? “–systemd-mark” was added in 3.8


#18

our version of nbd-client is too old, We will build a new initrd with an up-to-date nbd-client


#19

@Kristian_Klausen: Can you try again ? I just updated nbd-client to version 3.8


#20

Weird… It seems like something goes wrong in the initramfs. http://m.imgur.com/QIkUxYp

Is there a way, I can get more output?
Edit: http://m.imgur.com/sMl62Sk