Multiple Fedora problems with update and upgrade issues


#1

I was thinking of moving a scaleway server from CentOS to Fedora so fired up the cheapest START1-XS instance with the Fedora 28 image to experiment with. The plan to update it through to Fedora 29 first. Didn’t go smoothly…

First off a simple dnf update just to bring Fedora 28 up to date failed with dependency issues. The reason turned out to be that in the Scaleway supplied image the updates-testing repository is enabled by default which it shouldn’t be. So I disabled it in repo config and could then complete an update.

Next I rebooted to check all was okay but boot failed with multiple SElinux errors. I then interrupted the next grub boot and manually added selinux=1 enforcing=0 to the command line. That caused SELinux to relabel the volume during boot and successfully complete. Subsequent boots worked with enforcing enabled again.

Finally I did a system upgrade to Fedora 29 which I expected to probably fail horribly given the earlier problems but amazingly it worked and rebooted into Fedora 29 complete with correct kernel.

So someone from Scaleway needs to fix that broken Fedora 28 and even better add a new not broken image of Fedora 29. I haven’t tested if the Fedora 28 image is also broken on larger servers but it certainly is for the 25 GB image for the START1-XS.

The good news is that an upgrade in place from Fedora 28 to Fedora 29 seems to work okay once you get there in the end.


#2

Bumping this topic - is Fedora going to be upgraded to 29? 28 will be EOL’d in about 6 months. In-place upgrade works but this is not the way to go for new images.


#3

The Scaleway image for Fedora on ARM-32 is still stuck at Fedora 22 from 2015 so holding breath waiting is not recommended!


#4

MEH! Which images are up-to-date? Debian stable? :smiley:


#5

As a long term scaleway user (since beta test) I’ve found it difficult to understand why even simple fixes and actions are virtually never implemented. The logical assumption is that someone in the management chain is supremely incompetent and while others come and go the problem remains.


#6

That’s so sad, especially that Fedora is such a great distro. It’s stable yet you get new packages every 6 months. And generating a new image is not a big deal.


#7

Given that the volume of posts here isn’t huge you would like to think Scaleway staff read them. In the early days technical staff did engage in discussion here and were very helpful but that doesn’t happen now. I suspect that is because they are not allowed to however maybe they just genuinely don’t care.

Keeping the images updated is as you say no big deal at all but if resources aren’t allocated then nothing will happen no matter how trivial the required work.