Migrate from OVH to Scaleway

#1

Hi all,

I’am studing to migrate from OVH to Scaleway (k8s managed, container registries, …) but I need to clarify some elements to act it:

  1. Do you support Helm Chart Museum in the container registry ?
    If no, it is a possibility in future ? Any ETA ? Any alternative ?

  2. In OVH, we can seperate context (ex: client1, client2) to make for example seperate facturation, accounts, …
    Do you provide this ? Or we need to create one account per context ?

Thx for your help and your responses !

#2

Hello,

  1. Yes, it is supported
  2. This feature is currently not yet supported but it is under active development and will be available soon (In French: https://www.nextinpact.com/brief/console-scaleway---l-acces-multi-utilisateurs-arrive--la-gestion-plus-fine-des-tokens-d-ici-fin-juin-12473.htm)

Benedikt

#3

Hi @bene and thx for your answer.

  1. Can you provide a documentation on how to use Helm Chart museum with your offer ?
    I can pull and push images but I can’t see how to push and pull helm charts.

  2. Okay good news :slight_smile:

Have a good day !

#4

@bcarriou you just need to tell Helm to use the registry URL (with the proper namespace) :slight_smile:

#5

Hi @PatrikCyvoct,

I’am not arrived to do this :confused:

For example, I run this command and it’s works:

docker login rg.fr-par.scw.cloud/kereval -u nologin -p mypwd

My namespace is kereval.

I tried this to push helm charts:

helm push --username=nologin --password=mypwd gitlab-runner-0.12.2.tgz https://rg.fr-par.scw.cloud/kereval

But I received this response:

Error: 404: could not properly parse response JSON: 404 page not found
Error: plugin "push" exited with error

What’s is wrong ?

Thx for your help

#6

@bcarriou could you try with https://rg.fr-par.scw.cloud/kereval/my-dummy-chart ?

#7

I have tried this commands but not works:

helm push --username=nologin --password=mypwd gitlab-runner-0.12.2.tgz https://rg.fr-par.scw.cloud/kereval
helm push --username=nologin --password=mypwd gitlab-runner-0.12.2.tgz https://rg.fr-par.scw.cloud/kereval/gitlab-runner-0.12.2
helm push --username=nologin --password=mypwd gitlab-runner-0.12.2.tgz https://rg.fr-par.scw.cloud/kereval/gitlab-runner-0.12.2.tgz

If I tried on my VMware harbor registry, it’s works:

helm push --username=admin --password='mypwd' gitlab-runner-0.12.2.tgz https://myregistry/chartrepo/kereval
Pushing gitlab-runner-0.12.2.tgz to https://myregistry/chartrepo/kereval...
Done.
#8

Hum… first helm push dosent exist on my end :thinking:
Basically I’m doing:

helm3 registry login -u scw rg.fr-par.scw.cloud/<my_ns>
helm3 chart save <path_to_my_chart> rg.fr-par.scw.cloud/<my_ns>/<my_chart_name>
helm3 chart push rg.fr-par.scw.cloud/<my_ns>/<my_chart_name>:<generated_tag>

And it works

1 Like
#9

Hi !

It’s works, thx :slight_smile: