Load Balancer not forwarding requests

#1

I have a LoadBalancer and an Instance

The config is as follows:

     loadbalancer:
    ip: 51.159.26.137
    frontend:
        name: kilby
        connected_to: merkle
        ssl-cetificate: certname
        port: 80
    backend:
        name: merkle
        server_ips: 10.64.114.105
        protocol: http
        port: 80
        proxy: disabled
        sticky_session: disabled
        cookie_name: none
        health_check: added one
    backend_status:
        server_ip: 10.64.114.105
        state: running
        status: passed
    ssl-certificate:
        name: cert name
        status: created

I have also tried setting the ip to the external IP instead of the internal on (10.64.114.105) but to no avail.

Can’t figure out what I did wrong.

Thanks,
Gaurav

#2

Hi,
you have activated HTTPS and used the port 80 (the default is 443 for HTTPS) so your site is accessible at https://51.159.26.137:80/ ( you must set the port in the url )

#3

Thank you so much, it works!