IPv6 on arch with dhcpcd

#1

Hi,

I have a dedicated server and want to use IPv6. I followed the instructions on https://documentation.online.net/en/dedicated-server/network/ipv6/prefix

However, this setting seems to be incompatible together with dhcpcd which accquires the IPv4 address.
I’m now trying to setup ipv6 usisng dhcpcd as well. my current problem is, that I have written the /etc/dhcpcd.duid file with the DUID from my console.online.net page, but dhcpcd tells me in the logs, that it uses a completely different DUID. How can I force dhcpcd to use a specific duid to request an IP address?

Does anyone have a complete setup for dhcpcd?

the problem using dhclient like written in the tutorial is:
Can’t bind to dhcp address: Address already in use.
It does not work for some reason. It worked for years, but stopped recently.
When I disable DHCPCD it works again. But in this case my server does not get an IPv4 address.

#2

Hi!
I’m not really sure to understand your issue.
But maybe, this documentation about dhcpcd and IPv6 could help you:
https://wiki.archlinux.org/index.php/IPv6#With_dhcpcd
If not, do not hesitate to write back on this message with more information (logs, configuration files…)

Good luck :wink:

#3

Hello,

I solved my problem. The file to write the DUID in is:
/var/lib/dhcpcd/var/lib/dhcpcd/duid

Writing the duid to this file and using this: https://community.scaleway.com/t/tutorial-ipv6-with-dhcpcd/3804, it works.

1 Like