How do I make cloud-init work with new kernel?

#1

I upgraded the kernel on my Fedora image. When I reboot with console, it gets this ERROR:

[ 6.000251] cloud-init[453]: 2020-01-02 00:41:30,315 - stages.py[ERROR]: Unable to render networking. Network config is likely broken: No available network renderers found. Sea
rched through list: [‘eni’, ‘sysconfig’, ‘netplan’]

Despite this, the network is active, and I can ping IPv6 and VPN IPs. But sshd is not started yet.
After a long wait, it shows a table with the private IP on ens2. But cloud-init keeps getting errors:

[ 242.657047] cloud-init[594]: 2020-01-02 00:45:26,974 - url_helper.py[WARNING]: Calling ‘http://10.19.123.123/latest/meta-data/instance-id’ failed [105/120s]: request error [HTTP
ConnectionPool(host=‘10.19.123.123’, port=80): Max retries exceeded with url: /latest/meta-data/instance-id (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object
at 0x7fa8fe1ed050>: Failed to establish a new connection: [Errno 111] Connection refused’))]

After 5 minutes or so, cloud-init finally gives up, and the system works normally.

Should I just disable cloud-init? What is it supposed to do? It is something added by scaleway.