Can't enable ufw firewall on Ubuntu 16.04 Baremetal server


#1

Hi,
I got a Baremetal basic server with ubuntu 16.04.
I configured my ufw to

ufw default deny incoming
ufw default allow outgoing
ufw allow ssh
ufw allow www
ufw allow ftp
ufw allow 443/tcp
ufw allow 25/tcp

However, when I try to do ufw enable, it hangs on the questions to which I reply y

Command may disrupt existing ssh connections. Proceed with operation (y|n)?

After that, I’ve to restart my server with hard reboot but it starts with ufw disabled.
Any suggestions?


#3

Hi Smarticle_LABS, I believe this should be for your help, [How to] Configures Iptables with INPUT rules (with dynamic NBD)

I know, @Scaleway should document much better their :poop::disappointed:


#4

I’m beginning to realise Scaleway are cheap for a reason… this little nugget has cost us half a day of head scratching across the team doing our 14.04 to 16.04 upgrade. Back to Digital Ocean I think.


#5

It works ok on one note and it is not ok one another node …
Any advice ?
syslog contains no relevant information.